SearchSearch   ProfileProfile   Log inLog in   RegisterRegister 

ssl certificates

 
Post new topic   Reply to topic    FirstSpot Forum Index -> Pre-sales Support Forum
View previous topic :: View next topic  
Author Message
paulm



Joined: 28 Jun 2008
Posts: 81

PostPosted: Sat Sep 01, 2018 4:31 pm    
Post subject: ssl certificates

Hi i am having a problem with a number of clients who's computers refuse to pick up the log on page, as is is dangerous and its certificate does not match etc and no matter what you cannot get the login page up, the only work round i have found so far is to copy the login page address and create a desktop short cut to that page, this is happening with firefox, chrome and microsoft edge
any suggestions
Back to top
alan
Forum facilitator


Joined: 26 Sep 2003
Posts: 4417

PostPosted: Mon Sep 03, 2018 3:17 am    
Post subject:

Assuming the you didn't turn on "SSL-enabled FirstSpot login page" as it is a different issue.

In general, the client device needs to access a http based page (e.g. http://php.net ) instead of https page, or otherwise you will get a cert warning. Another way is to simply rely on the captive portal detection (e.g. Captive Network Assistant in iOS or macOS) which will trigger the FirstSpot captive portal page correctly.
_________________
~ Patronsoft Limited ~
Back to top
paulm



Joined: 28 Jun 2008
Posts: 81

PostPosted: Sun Sep 09, 2018 4:01 pm    
Post subject:

Hi since i posted the original message i am having a lot more complaints that people can't get the log on page to activate this is coming from regular users who have been customers for years so i am concerned
you mentioned ssl enabled firstspot login page
should i have activated this?
and where is it i have missed it somewhere
thanks
Back to top
alan
Forum facilitator


Joined: 26 Sep 2003
Posts: 4417

PostPosted: Mon Sep 10, 2018 4:09 am    
Post subject:

No, please don't enable this feature at this moment.

Again, the key is that the client device needs to access a http page instead of https page. Alternatively, you can rely on the automatic captive portal detection. See https://support.apple.com/en-hk/HT204497 or https://android.stackexchange.com/questions/123129/how-does-wifi-in-android-detect-if-the-device-has-to-sign-in-or-not for more information.
_________________
~ Patronsoft Limited ~
Back to top
paulm



Joined: 28 Jun 2008
Posts: 81

PostPosted: Mon Sep 10, 2018 8:08 am    
Post subject:

Ok thank you the more i have checked it out the problem seems mainly to be coming from windows 10 machines, and once the security alert is up it is very difficult to get past i have tried the http route but the problem is that transient clients i.e. 1 day 1 week etc don't want to know about this as they just want instant use, they already have had a warning that the system is open then they get the warnings about ssl etc and then want their money back
Back to top
alan
Forum facilitator


Joined: 26 Sep 2003
Posts: 4417

PostPosted: Mon Sep 10, 2018 8:23 am    
Post subject:

For Windows 10 client, the automatic captive portal detection should work very well. Please double check with your Wi-Fi network setup to make sure the client select the correct AP SSID.

Also, note that the behavior for FirstSpot between v7 and v8 remain unchanged in this area.
_________________
~ Patronsoft Limited ~
Back to top
Display posts from previous:   
Post new topic   Reply to topic    FirstSpot Forum Index -> Pre-sales Support Forum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group